Some test text!

Loading...
Guides
SWIG uses the wrong version of Python to compile my wrappers

SWIG uses the wrong version of Python to compile my wrappers

If SWIG does not use the Python version and libraries you intend to build the wrappers with, navigate to PDFNetWrappers/PDFNetPython and add a version requirement to the line find_package(PythonLibs). For example, if SWIG is targeting Python 3.7 but you want to compile the wrappers with Python 2.7, change the line to

find_package(PythonLibs 2.7 EXACT REQUIRED)

Note you must have the python version installed on your OS in order for SWIG to target that version. pyenv can help you install another version of Python.

Get the answers you need: Support